Вернуться   Дизайнерский форум » ДИЗАЙН И ГРАФИКА » Технологии Flash

Проблема с флеш в Опере

Обсуждение темы Проблема с флеш в Опере в разделе Технологии Flash, часть категории ДИЗАЙН И ГРАФИКА; У меня на сайте раньше была такая проблема, что в Опере флеш отображалось "не активным". То есть активизировалось только после щелчка по нему. ...


Закрытая тема
 
Опции темы
Старый 24.04.2010, 00:15   #1
У меня на сайте раньше была такая проблема, что в Опере флеш отображалось "не активным". То есть активизировалось только после щелчка по нему. (если наводишь на него курсор, то писало - "щелкните чтобы активировать элемент")

Я поспрашивал советов на форумах и мне предложили решить проблему вот этим скриптом:
PHP код:
<script src="/AC_RunActiveContent.jstype="text/javascript"></script>
<script src="/AC_ActiveX.js" type="text/javascript"></script>

<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0','width','600','height','250','src','test','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','Stroitelstvo','wmode','opaque'); //end AC code
</script>
<noscript>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" "http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0"  width="100%" height="100%">
<param name="movie" value="Stroitelstvo.swf" />
<param name="quality" value="high" />
<embed src="/Stroitelstvo.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer"  type="application/x-shockwave-flash"  width="600" height="300" wmode="opaque"></embed>
</object>
</noscript> 
Но теперь этот скрипт почему-то перестал работать... (хоть я даже не изменял код страниц сайта - флеш просто резко перестало нормально работать - с этим скриптом флеш вообще перестало грузиться... Поэтому я поставил флеш обычным способом - без этого скрипта, чтоб оно хотя бы вообще отображалось...)

Может кто знает другой способ или скрипт чтоб флешка нормально работала и не нужно было по ней щелкать чтоб активировать?

PS Такая проблема возникает только в Опере и некоторых других браузерах. (в фаерфоксе все нормально...)
Помогите!

Добавлено через 1 час 46 минут

PS сайт spartis.by

Последний раз редактировалось -=VIR=-; 24.04.2010 в 00:15.. Причина: Добавлено сообщение
 
Старый 24.04.2010, 00:15
Ссылки
Старый 24.04.2010, 01:03   #2
-=VIR=-, а поиск по сайту не пробовали?
смотреть здесь
 
Старый 24.04.2010, 11:42   #3
Спасибо большое!
 
Старый 25.04.2010, 18:36   #4
Мне кажытся тот код не пашет, у меня всёравно просит активировать.. А вообще это решается простой вставкой кода на JS сделать фокус на флеш объекте, завтро кину строку, щас её не помню..смысл в том что после загрузки по ExternalInterface дёргается скрипт а тот ставит фокус и всё пашет во всех браузерах
 
Старый 25.04.2010, 18:36
Закрытая тема


Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Кэш в Опере 74ivan74 Кальянная 6 10.08.2011 13:33
В опере chelpsix ASP, Perl, PHP и MySQL 2 13.09.2010 19:52
Проблема с флеш шаблоном Biata Технологии Flash 7 26.07.2009 09:14
чудо в опере sokol666 Кальянная 14 14.07.2008 07:32
Проблема с недозагрузкой флеш роликов на Web страничке, почему??? tgrisha Технологии Flash 4 03.07.2005 01:59


Текущее время: 01:39. Часовой пояс GMT +4.

Реклама на форуме Условия размещения рекламы
Биржа ссылок Заработай на сайте!
Тарифный план «Lite»
Место: 1000 Мб
Трафик: неограниченный
Панель управления
Заказать ТП «Lite»
Тарифный план «Normal»
Место: 2000 Мб
Трафик: неограниченный
Поддержка скриптов
Заказать ТП «Normal»
Тарифный план «Profy»
Место: 7000 Мб
Трафик: неограниченный
Поддержка скриптов
Заказать ТП «Profy»
Тарифный план «Места хватит!»
Место: 25 ГБ
Трафик: неограниченный
Поддержка SSI, ssh
Заказать ТП «Места хватит!»
Дизайнерский форум